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6Abstract

7The Biological NetworkManager (BiNoM) is a software tool for the manipulation and analysis of biological
8networks. It facilitates the import and conversion of a set of well-established systems biology file formats.
9It also provides a large set of graph-based algorithms that allow users to analyze and extract relevant
10subnetworks from large molecular maps. It has been successfully used in several projects related to the
11analysis of large and complex biological data, or networks from databases. In this tutorial, we present a
12detailed and practical case study of how to use BiNoM to analyze biological networks.
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141 Introduction

15The last decade has seen unprecedented advances in the production
16of high-throughput experimental data in biology, fueled by drastic
17technological improvements in various ways of measuring
18biological entities. In return, those large amounts of biological
19information have stimulated the need of developing standards for
20an efficient representation and exchange of data. This is especially
21true for the field of systems biology, which aims at building models
22and quantitative or qualitative simulations of complex biological
23systems [1, 2]. To achieve this goal, it is obvious that a good
24communication and collaboration between modelers and experi-
25mentalists having various scientific backgrounds will be facilitated
26by the standardization of the representation of workflows, data
27formats, and mathematical models. Several complementary stan-
28dards have already been created and are increasingly used in a large
29variety of projects. Most of them are based on an open-source
30and community-based organization, ensuring an easy access to
31the detailed specifications of the standard, flexibility, dynamic
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32evolution, and wide acceptance. Examples of such community
33standards are the System Biology Markup Language (SBML) [3],
34a language focused on mathematical modeling, the Biological Path-
35way Exchange standard (BioPAX) [4], devoted to storing and
36exchange of pathway information and the Systems Biology Graphi-
37cal Notation (SBGN), centered on the graphical notation for
38biological maps [5]. It is worth noting that there are now more
39than 40 databases and online resources supporting the BioPAX
40format, while more than 33 databases are using SBML (http://
41www.pathguide.org). Well-established examples are the Reactome
42database [6], BioModels [7], and MINT [8]. More and more
43systems biology software packages are also using standard formats
44to store and exchange data. For example, CellDesigner is a tool
45used to edit biological pathways diagrams [9] and is using a com-
46patible SBML dialect to store the all the information related to
47a given diagram. Cytoscape is a widely spread program used for
48the visualization, modeling, and analysis of complex molecular
49and genetic interaction networks [10]. BiNoM was developed as a
50Cytoscape plugin, with the goal of facilitating the import and
51export of various systems biology formats, and also proposing a
52large set of graph-based algorithms for the extraction of relevant
53subnetworks from large molecular maps [11]. BiNoM was success-
54fully used in several projects related to the analysis of complex
55biological networks [12]. Here, we present a set of detailed and
56concrete examples of how to extract relevant information from such
57maps using BiNoM.

582 Material

59The Cytoscape [10] software should be installed on the computer
60(http://cytoscape.org). The BiNoM plugin can be installed in
61different ways. The first is to download BiNoM from our web
62page (http://bioinfo-out.curie.fr/projects/binom/) and copy the
63file under the directory “plugins” of the Cytoscape installation
64folder (administrator privileges might be necessary to perform
65this operation). The latest version of BiNoM (version 2.0) supports
66the latest versions of Cytoscape. The previous version (BiNoM 1.0)
67is also available on our website for older versions of Cytoscape.
68Another possibility to install BiNoM is to use the plugin man-
69ager of Cytoscape. Starting in version 2.5, the plugin management
70has been added to allow users to search for, download, install,
71update, and delete plugins within Cytoscape.

721. Select the function “Plugins>Manage Plugins” from themenu.

732. Navigate in the tree view to the category “Analysis.”
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743. Select BiNoM v2.0 (or any more recent version available).

754. Click “Install.”

76All the files used throughout this tutorial can be downloaded
77from our website (http://bioinfo-out.curie.fr/projects/binom/).

783 Methods

3.1 Import

and Export

79A major function of the BiNoM software is to provide import and
80export functions for a given number of standard systems biology file
81formats. It is therefore possible to import data from SBML level
822 files, CellDesigner 3.X and 4.X files, BioPAX level 3, CSML files
83and also from simple text files formatted to the AIN (Annotated
84Influence Network) format. The aim of BiNoM import/export
85functions is not to be a universal converter but rather to favor a
86number of scenarios where the conversion is making sense (Fig. 1).
87It is worth mentioning that due to major changes in the specifica-
88tions, the BioPAX level 3 format is incompatible with the previous
89level 2 format [4]. The previous version of BiNoM (version 1.0, still
90available from our website) was managing the BioPAX level 2, but
91the latest version of BiNoM (2.0) can only deal with BioPAX level 3
92files. The current version of Cytoscape does not support a direct
93import of BioPAX level 3 files yet [10].
94Let us take an example. The model of the yeast cell cycle by
95Novak and colleagues [13] was encoded as a graph using CellDe-
96signer software [9]. We can easily import it in Cytoscape using the
97BiNoM functions. The file is available on the BiNoM website (file
98name: M-Phase.xml).

991. Select the function “Plugins > BiNoM 2.0 > BiNoM I/O >
100Import CellDesigner document from file” from the menu.

1012. Select the file from the dialog window.

1023. Click OK.
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Fig. 1 The BiNoM import/export functions favor a number of scenarios that are
illustrated on the figure (left side: import file formats, right side: export file
formats). Note that for the CellDesigner to CellDesigner conversion, it is possible
to split the network, change the layout, and change the color and the scale
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1034. A new network is created as “M-Phase.xml” with 36 nodes and
10442 edges (Fig. 2).

105BiNoM uses its own visual mapping to represent the different
106molecules and their interactions, inspired by the SBGN standard
107[5], but presents a simplified version of it. For example, simple
108proteins are represented by white circles, while protein complexes
109are pictured as gray circles. Similarly, there is a specific mapping for
110the different relationships between molecules: for example, a catal-
111ysis relation will be represented as a red colored edge with a circular
112end. Figure 3 shows the BiNoM visual styles for BioPAX and
113CellDesigner. When importing pathway information, BiNoM gen-
114erates meaningful names for every chemical species, following pre-
115established rules. Chemical species are defined as physical entities
116(e.g., a protein) with an optional cellular localization and posttrans-
117lational modifications. The name formatting rules are as follows:

118(Entity1_name|Modification:Entity2_name|Modification)
119[_active|_hmN]@compartment

120The colon symbol “:”delimitates the different components of a
121complex, the vertical bar “|” indicates the posttranslational mod-
122ifications, while the “@” sign indicates the cellular compartment.
123The optional suffixes “active” or “hm” indicate the state of the
124chemical species and N-homodimer state, respectively. The par-
125entheses delimitate the components concerned by the N-
126homodimer state and are useful to eliminate ambiguities (see
127Fig. 2 for examples).
128We have recently developed a new import format-denominated
129AIN. The principle of this format is to encode an influence net-
130work, where edges represent either an inhibition or an activation,
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Fig. 2 Zoom on a simple cell cycle network imported from CellDesigner into Cytoscape using BiNoM
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131into a simple tab-delimited text file (see Table 1 for a detailed
132explanation of the AIN format). Using this format, it is rather
133straightforward for a biological expert to encode a network from
134his AU1own expertise and/or from published results, using a spread-
135sheet program such as Excel, and then import it in Cytoscape using
136BiNoM, rather than using more sophisticated tools such as Cell-
137Designer. All the information contained in the AIN file is automat-
138ically converted in the BioPAX format when the file is imported and
139can be subsequently retrieved with specific BiNoM functions. Let
140us now import a simple cell cycle model encoded as an AIN file

141(cell_cycle_AIN.txt, available from the BiNoM website).

1421. Select the function “Plugins > BiNoM 2.0 > BiNoM I/O >
143Import influence network from AIN file” from the menu.

1442. Select the file “cell_cycle_AIN.txt” from the dialog window
145and click OK.

1463. Click OK twice, for the windows “Defining families” and
147“Select constitutive reactions to add.”

1484. The network is imported as “cell_cycle_AIN” (Fig. 4).
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Fig. 3 Comprehensive visual representations followed by the BiNoM software for different entities and their
relationships, for both the BioPAX and CellDesigner file formats
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149

3.2 Manipulating

Existing Networks

150The cell cycle model of Novak et al. (Fig. 2) has 36 nodes and 42
151edges in total, making it a rather small network. However, this is
152not very often the case. On the contrary, most networks publicly
153available from online databases such as Reactome [6] or large
154molecular maps built from the literature such as the RB/E2F map
155[12] have hundreds of nodes and edges, if not more. Such gigantic
156maps are barely readable and manageable when imported into
157visualization software such as Cytoscape. One of the main ideas of
158BiNoM plugin was to provide a set of network tools allowing users
159to extract meaningful subnetworks from large molecular maps and
160also to provide means to understand and read these maps [11]. We
161will see now through a set of examples how to extract such mean-
162ingful subnetworks.

t:1 Table 1
Description of the AIN format

Column
number

Column
caption Description Example(s)t:2

1 ReviewRef A reference (e.g., a PubMed ID) to an
article

PMID:1234t:3

2 ExperimentRef A reference to an experiment PMID:10783242t:4

3 Link Connection (activation or inhibition)
between two entities. The name can
represent a single protein, a protein
complex “(C:D),” a phosphorylated
protein “(C^p),” or a family. For the
latter, the family can be given explicitly
by the full list of the members “(C1, C2,
C3),” or implicitly by using an undefined
name where a dot will represent any
character “(C.)”

“A->B,” “A-|B,” “((CCNE.):
CDK2)->E2F5^p,” “(E2F1,
E2F2)->CDKN2A”t:5

4 ChemType Chemical type of the reaction Bindingt:6

5 Delay Delay of the reaction (numerical value
and unit)

0.9 ht:7

6 Confidence Confidence level in the reaction
(value between 0 and 1)

0.8t:8

7 Tissue Tissue where the reaction has been
observed

Fibroblastt:9

8 Comment Comment about the reaction “Specific phosphorylated site of
E2F5”t:10

t:11 Each line of the table represents a column of the AIN tab-delimited file. Columns are numbered from left to right.

Missing values should be indicated by a single dot and text strings should be quoted. The only mandatory column is the
Link (column number 3), representing the reaction

Eric Bonnet et al.



163As a first exercise,we create a simplermodular viewof theM-phase
164example.Let us first decompose the cell cyclemapwehave imported in
165the previous paragraph by pruning the graph. In large networks, this
166step is important in order to simplify the network: we work on the
167connected graph rather than the whole graph.

1681. Select the network “M-Phase.xml.”

1692. Choose the function “Plugins > BiNoM 2.0 > BiNoM
170Analysis > Prune Graph” in the menu.

1713. Three networks are created: “M-Phase.xml_in,” “M-Phase.
172xml_scc,” and “M-Phase.xml_out.”

173The function is decomposing any network in three components
174corresponding to the nodes that are coming in (input), the nodes
175that go out (output), and the central cyclic part. The central part
176may sometimes be composed of several strongly connected compo-
177nents. In some situations they can be disconnected, forming several
178subnetworks. The decomposition of the strongly connected com-
179ponents part can be done in two ways: (1) by cycle decomposition
180and (2) by material components decomposition. Let us first see
181how to decompose a network into relevant directed cycles, which
182usually provides information about the life cycle of a gene or
183protein of the network.
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Fig. 4 A cell cycle network imported from an AIN text file (Annotated Influence Network)
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1841. Select the network “M-Phase.xml_scc” (highlighted in the
185Cytoscape navigation panel).

1862. Select the function “Plugins > BiNoM 2.0 > BiNoM Analysis
187> Get cycle decomposition” from the menu.

1883. Three new networks are created: cycle1, cycle2, and cycle3
189(Fig. 5).

190Let us now merge in clusters networks that share a certain
191number of components.

1921. Select the function “Plugins > BiNoM 2.0 > BiNoM Analysis
193> Cluster Networks” from the menu.

1942. In the dialog window that appeared, select the networks cycle1,
195cycle2 and cycle3 (holding down the CTRL key for multiple
196selection).

1973. Set the intersection threshold to 35 % using the sliding bar.

1984. Click OK. Two networks are created: “cycle1” and “cycle2/
199cycle3.”

200In fact, only the networks cycle2 and cycle3 were clustered,
201because they share a component (Cdc25 phosphorylated and
202active; in a two-component network, they share more than 35 %).
203Now that the modules are created, we need to include the inputs
204and outputs that were put aside at the beginning of the analysis.
205In order to merge networks, we can use a Cytoscape built-in
206function.

T
h
is

fi
g
u
re

w
ill
b
e
p
ri
n
te
d
in

b
/w

Fig. 5 Subnetworks (cycles) extracted from the M-Phase network using BiNoM functions
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2071. Select the function “Plugins > Advanced Network Merge”
208from the menu.

2092. Fromthedialogwindow, select “Union” in thefield “Operation.”

2103. In the list of networks, select “Cycle1,” “M_Phase.xml_in,”
211and “M_Phase.xml_out” and then click “Merge.”

2124. The resulting network is named “Union” and should have 30
213nodes and 19 edges.

2145. Rename the network to “Union1” by right-clicking on its
215name and selecting “Edit Network Title.”

2166. Using the same procedure as above, merge the networks
217“cycle2/3,” “M_Phase.xml_in,” and “M_Phase.xml_out.”
218The resulting network should have 22 nodes and 12 edges.

2197. Rename it to “Union2/3.”

220Some edges present in the original file have been lost during all
221these operations, and they need to be included again. For that, we
222will now update the networks.

2231. Select the function “Plugins > BiNoM 2.0 > BiNoM Utilities
224> Update connections from other network” from the menu.

2252. In the dialog window, select “M-Phase.xml” for the field
226“From Network” and select the networks “Union1” and
227“Union2/3” from the list “Networks to Update,” and click
228OK.

2293. The networks “Union1” and “Union2/3” are updated to 30
230and 20 edges, respectively.

231We can now remove unconnected and unnecessary components.

2321. Select the network “Union1.”

2332. Change the layout by using the Cytoscape function “Layout >
234yFiles > Organic” from the menu (this step allows to visualize
235the unconnected components more easily).

2363. Select all unconnected nodes and remove them.

2374. The Wee1 and Rum1 genes should be in a network of their
238own, so we propose to remove them and all the edges
239connected to them (they are in fact important proteins that
240do not share a function with the two modules created).

2415. The resulting networks should have 20 nodes and 20 edges for
242“Union1” (Fig. 6) and 8 nodes and 9 edges for “Union2/3”
243(Fig. 7).

244Note that the analysis requires to make a certain number of
245choices, based on biological knowledge and related to the final goal
246of the user. Here, we want to create a modular view of the initial
247network to highlight the main mechanisms involved in the yeast cell
248cycle progression. Finally, we can now generate a modular view
249from the networks Union1 and Union2/3.

Practical Use of BiNoM: A Biological Network Manager Software



2501. Select the function “Plugins > BiNoM 2.0 > BiNoM module
251manager > Create Network of Modules” from the menu.

2522. Select “Union1” and “Union2/3” from the list in the dialog
253window and click OK.

2543. Select the function “Plugins > BiNoM 2.0 > BiNoM
255module manager > Create connections between modules”
256from the menu. Select the network “M-Phase.xml” from the
257list in the dialog window and click OK.
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Fig. 7

AU2

A subnetwork resulting from the union of two subnetworks
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Fig. 6 A subnetwork resulting from the union of two subnetworks
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2584. Rename the network to “Module1” by right-clicking on it
259(Fig. 8).

260The resulting map is a modular map of the initial network, in
261which modules participate in a specific process. For instance,
262“Union 1” shows all the events that lead to the activation of the
263maturation promoting factor, a heterodimer composed of the
264cyclin-dependent kinase Cdc2 and the cyclin B protein Cdc13.
265Note that in order to navigate from a module to the corresponding
266subnetwork, you have to perform the following operations:

2671. Right-click on the module of interest. A contextual menu
268appears.

2692. In the menu, choose “Nested Network” and then “Go to
270Nested Network.” The corresponding subnetwork is now
271brought to the front window.
272

3.3 BiNoM

and BioPAX Files

273Biological Pathway Exchange (BioPAX) is a standard language that
274represents biological pathways at the molecular level and facilitates
275the exchange of pathway data [4]. The current BioPAX specifica-
276tion (level 3, released in July 2010; see http://www.biopax.org),
277supports representation of metabolic and signaling maps, molecular
278and genetic interactions, and gene regulation. Furthermore, there
279are several additional constructs available to store extra details such
280as database cross-references, chemical structures, sequence feature
281locations, and links to controlled vocabulary terms encoded in
282various ontologies (such as the Gene Ontology). BiNoM has a
283powerful set of functions to manage large BioPAX files, allowing
284the user to import, export, analyze, and extract the knowledge
285encoded using this specification [11]. We have recently updated
286the BiNoMplugin software to provide support for the latest BioPAX
287specification (level 3; see http://www.biopax.org/specification.
288php).

3.3.1 Import and

Information Extraction

from a BioPAX File

289In the next example, we will be working with a relatively large
290molecular map representing the Apoptosis pathway in human,
291extracted from the Reactome database [6]. The file is available
292from our website (Apopotosis3.owl). Let us import the file in
293Cytoscape using BiNoM functions.
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Fig. 8 A modular representation of two subnetworks, Union2/3 and Union1
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2941. Select the function “Plugins > BiNoM 2.0 > BiNoM I/O >
295Import BioPAX 3 Document from file” from the menu.

2962. Select the file “Apoptosis3.owl” from the dialog box.

2973. A new dialog window appears. The three types of network
298should be imported. For that, check the boxes “Reaction Net-
299work,” “Pathway Hierarchy,” “Make Root Pathway Node,”
300“Include Pathways,” “Include Interactions,” and “Interaction
301map.”

3024. Click OK. Three new networks are created, corresponding to
303the reaction network (“Apopotosis3 RN”), Apoptosis Pathway
304(“Apoptosis3 PS”), and Apoptosis protein–protein interactions
305(“Apoptosis3 PP”).

3065. Change the layout of eachnetwork for abetter readability: choose
307“Organic” (“Layout> yFiles>Organic”) for “Apoptosis3 RN”
308and “Apoptosis3 PP” and the type “Hierarchic” (“Layout >
309yFiles>Hierarchic”) for “Apoptosis3 PS.”

310The three networks represent different types of knowledge
311extracted from the BioPAX file. We call them network interfaces,
312because they allow to access the different parts of the content of a
313BioPAX file. The Reaction Network (RN) is a graph which contains
314nodes of two types: “species” and “reactions.” Proteins are repre-
315sented as white rounded squares, complexes as gray rounded
316squares, and reactions as small gray diamonds (Fig. 9c). The Path-
317way Hierarchy (PS) contains pathway knowledge with two types of
318nodes: pathways, pictured as green hexagons, and pathway steps,
319pictured as pink triangles (Fig. 9b). The last interface contains an
320interaction map (IM) extracted from the proteins and protein
321complexes present in the BioPAX file, with edges of type “contains”
322(Fig. 9a).
323The whole network being quite large, it is not always easy to
324find specific information. In the next example, we propose to query
325the graph by performing a simple analysis on a BioPAX imported
326file: the extraction of a path.

3271. Select the network “Apoptosis3 RN” by clicking on the name
328in the navigation panel.

3292. Select all nodes and edges by using the function “Select >
330Select All Nodes and Edges” from the menu.

3313. Select the function “Plugins > BiNoM Analysis > Path Analy-
332sis” from the menu.

3334. A dialog window appears; choose the node “TNF:TNFR1@plas-
334ma_membrane” in the “Sources” list and the node “GIG3:RIP:
335TRADD:TRAP3@cytosol” in the “Targets” list.

3365. Take the default search options “Find shortest paths” (you can
337try the other options as an exercise).

Eric Bonnet et al.



3386. Click OK. The nodes of the shortest path between the two
339nodes are now highlighted in the network (note that it is not
340the case for the edges connecting them).

3417. Extract the path as a new network by using the function “File>
342New > Network > From selected nodes, all edges” from the
343menu.

3448. A new subnetwork is created with the name “Apoptosis3 RN—
345child.”
346

3.3.2 Querying

a BioPAX File

347The BioPAX format is now used by an increasing number of data-
348bases and online repositories such as Reactome (http://www.reac-
349tome.org), Cancer Cell Map (http://cancer.cellmap.org), the
350Pathway Interaction Database (http://pid.nci.nih.gov/), or Path-
351way Commons (http://www.pathwaycommons.org). The amount
352of information contained in the files extracted from those databases
353can be very consequent, making it difficult for the average user to

APTL:CD95:APTL:CD95:APTL:CD95:@plasma_membrane

APTL:CD95@plasma_membrane

a

c

b

APTL@extracellular_region

CD95@plasma_membrane

CAM_PRP_catalytic_subunit:Calcineurin_B1_alpha_regulatory@cytosol

BAD_protein@cytosol

KCIP_1@cytosol

Sequestration_of_BAD_protein_by_14_3_3

KCIP_1:Phospho_BAD|phosphorylated_residue_MOD:00696@cytosol

Phospho_BAD|phosphorylated_residue_MOD:00696@cytosol

Akt1_phosphorylates_BAD_protein

PKB@cytosol

Activation_of_BAD_by_calcineurin

Intrinsic_Pathway_for_ApoptosisStep

Intrinsic_Pathway_for_Apoptosis

Activation_of_BH3_only_proteinsStep

Activation_and_oligomerization_of_BAK_proteinStep

Permeabilization_of_mitochondriaStep
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Fig. 9 Three types of networks resulting from the import of a BioPAX file. (a) Reaction network (RN).
(b) Pathway hierarchical structure (PS). (c) Protein–protein interaction network (PP)
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354efficiently query and retrieve relevant data. We have included in
355BiNoM an efficient BioPAX querying system. The BioPAX file is
356converted to an index, by mapping the BioPAX content on a
357labeled graph. This index can then be queried by the user for
358specific elements of interest. The result is returned as a graph
359directly in Cytoscape and can be further extended to include vari-
360ous elements such as all the complexes in which a protein of interest
361is involved, the reactions connected to those molecules, and the
362related publications. For example, let us extract the complexes
363related to a given protein from the Apoptosis BioPAX file.

3641. First, we have to generate the index from the BioPAX file.
365Select the function “Plugins > BiNoM 2.0 > BiNoM BioPAX
3663 Query > Generate Index” from the menu.

3672. From the dialog window that appears, select the file “Apopto-
368sis3.owl” for the field “BioPAX File.” The second field named
369“Index File” will be filled automatically with the same file
370name, just changing the extension to “.xgmml.” In this case,
371it will suggest the name “Apoptosis3.xgmml”; you can change
372that name if you wish or just accept the proposition. Click OK.
373The index is generated and saved.

3743. Load the index with the function “Plugins > BiNoM 2.0 >
375BiNoM BioPAX 3 Query > Load Index” from the menu.
376Select the index file you have just created “Apoptosis3.
377xgmml” and click OK. The index is now loaded in memory
378(note that loading the index is an essential step to perform a
379query; the creation of the index is not enough).

3804. Basic statistics related to the index file content can be obtained
381by the function “Plugins > BiNoM 2.0 > BiNoM BioPAX 3
382Query > Load Index” from the menu. A window is displayed
383containing a table with counts for different elements of the
384index (proteins, complexes, publications, etc.).

3855. Let us now do a basic query. Select the function “Plugins >
386BiNoM2.0> BiNoMBioPAX 3Query> Select Entities” from
387the menu.

3886. In the text field entitled “Input,” type the name “SMAC,” and
389click OK. A new network is created, having a single node
390named “SMAC@cytosol.”

3917. For a better visualization, you can set the visual style to
392“BiNoM BioPAX” on the tab “VizMapper” on the left-hand
393side of the Cytoscape interface.

3948. Now we wish to expand this network by adding all the com-
395plexes in which this protein is involved. Select the function
396“Plugins> BiNoM 2.0> BiNoMBioPAX 3Query> Standard
397Query” from the menu. A window appears, named “BioPAX
398Standard Query from the index.” Check the boxes for the
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399option “Add complexes” and “expand.” Un-select the boxes
400“Add chemical species,” “Add reactions,” and “Add publica-
401tions.” Verify that the option “All nodes” is checked for the
402“Input” section and that “Output in the current network” is
403checked for the “Output” section (by checking those options,
404we make sure that all the nodes are by default selected as input
405and that the result of the query will be added to the current
406network). Click OK.

4079. Several nodes and edges have been added to the current net-
408work. For a better visualization, adjust the layout with the
409function “Layout > yFiles > Organic” from the menu. A
410green arrow with a diamond ending represents the inclusion
411of one protein in a complex form. The resulting network
412should have 9 nodes and 11 edges (Fig. 10).

413As we have seen from the standard query interface, it is possible
414to expand the network by including the chemical species, the reac-
415tions connecting all present species that have a common reaction,
416and the publications related to any of the components of the
417network (for more information on how to use those options, please
418consult the BiNoM manual available from our website). Note that
419the resulting network of interest can be exported as a SBML or
420BioPAX file as described in the previous paragraphs.
421
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Fig. 10 A network constructed from a BioPAX query, centered on the SMAC protein, and including all protein
complexes where this protein is involved. Data extracted from the Apoptosis data of the Reactome database
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3.4 Other Useful

BiNoM Functions

422We have seen that BiNoM has several useful functions to extract
423relevant information from large-scale databases encoded with
424standards defined by the systems biology community. Very often,
425the results of those analyses will be one or more subnetworks of
426interest, possibly grouping a set of molecules involved in a particu-
427lar biological function (cell death, cell cycle, apoptosis, etc.). An
428example of such an insightful extraction of a subnetwork is shown
429in Calzone et al. [12], where a compact modular view of the RB/
430E2F pathway composed of 16 protein modules and 8 E2F target
431gene modules (see Fig. 3 of this chapter) was extracted from a
432comprehensive network of hundreds of different molecules and
433interactions. Once the map is constructed, several options are
434possible to generate interesting and useful insights. These options
435include (non-exhaustive list) (1) the creation of a computational
436predictive model, making possible the analysis of the consequences
437of deletion or mutation of various elements of the network, and (2)
438superimposing external and experimental available data related
439to the function of the network, in order to visually appreciate the
440effect of different states/perturbations/disease effects. For exam-
441ple, bladder tumor expression data was superimposed on the RB/
442E2F pathway compact representation mentioned above, for both
443invasive and noninvasive cases (see http://bioinfo-out.curie.fr/
444projects/rbpathway/case_study.html). The nodes of the network
445are then colored according to the averaged expression levels of the
446different modules, indicating what parts are over- or under-
447expressed. Clear differences can be seen between the invasive and
448noninvasive state of the tumor samples, informing of the evolution
449of tumors at the expression level of genes of the network.
450Let us now see an example of how to color a map using BiNoM
451functions, based on the M-phase network.

4521. Import the CellDesigner file M-Phase.xml as described in the
453Subheading 3.1.

4542. Now import values for each gene. They are stored in a simple
455text file having two columns “NODE_NAME” and “CON-
456CENTRATION.” Select the function “File > Import > Attri-
457bute from table (Text / MS Excel).” In this case, the values
458represent expression levels randomly generated, but they could
459be any type of scoring. Note that for experimental data, pro-
460teins with posttranslational modifications will not be colored.

4613. Select the input file “M-Phase-Expression.txt.” A preview of
462the file content should appear at the bottom of the dialog box.

4634. In the “Advanced” box, click the box “Show text file import
464options.”

4655. A new box appears, entitled “Attribute names.” Check the box
466“Transfer first line as attribute name.” Now the column titles
467should read “NODE_NAME” and “CONCENTRATION.”
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4686. Click on “Import.” The file is imported, and a new numerical
469attribute “CONCENTRATION” is created for all the genes.

4707. Now click on the “VizMapper” tab, on the left-hand panel of
471Cytoscape.

4728. In the “Visual Mapping Browser” box, click on the “Node
473Color” small triangle to display the properties.

4749. Change the property “Mapping Type” to “Continuous
475Mapping.”

47610. Change the value of “Node Color” to “CONCENTRA-
477TION.”

47811. Click on “Graphical View,” a new dialog box will appear. Set
479the minimal and maximal values according to the values of your
480dataset by clicking on the “Min/Max” button.

48112. Set the colors by clicking on the small triangles located above
482the minimum and maximum values. Click OK.

48313. The nodes of the network should be colored according to their
484expression value, as shown on the Fig. 11.
485

4864 Conclusion

487l Model building in systems (and mathematical) biology is a
488complex multistep process: from the definition of a suitable
489biological problem, knowledge is first collected and formalized
490into a network and then translated in mathematical terms.
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Fig. 11 M-Phase network (zoom) with nodes in shades of gray according to their expression values, ranging
from low values (light gray) to high values (dark gray)
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491BiNoM helps with intermediate steps of this process, in the
492construction of a network of biochemical or regulatory inter-
493actions, and in the analysis of the structural properties of this
494network. For this, BiNoM provides multiple ways: to access
495pathway databases through their BioPAX representations,
496manipulate (cut, decompose, reorganize) the network, apply
497algorithms from graph theory to the network, and map avail-
498able quantitative data on it.

499l The future developments of BiNoMwill include functions such
500as merging several independent networks, finding minimal
501intervention sets to disrupt or modify the signaling flow from
502a set of source nodes to a set of target nodes, and the ability to
503generate a code for web-based representations of biological
504networks using the Google Map API and semantic zoom.

505l BiNoM is not supposed to be a modeling software per se; it
506does not aim at implementing any engines for numerical simu-
507lations, but it has interfaces with external simulators through
508exporting networks to SBML and GINsim file formats (with
509use of GINsim Cytoscape plugin [14]). The main application of
510BiNoM is to facilitate the preparation phase of constructing,
511annotating, and structuring a biological network for further
512mathematical modeling and simulation, and this will determine
513its future development.

5145 Notes

515l Cycle decomposition can result in a huge number of cycles. It is
516advised to use it on small to moderate size networks.

517l When trying to divide a large network into subnetworks, an
518alternative to the cycle decomposition described in the Sub-
519heading 3.2 is the function “Get Material Components” from
520the menu “Plugins > BiNoM 2.0 > BiNoM Analysis.” This
521function is using node name semantics to isolate subnetworks
522in which each protein is involved.
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